Application Unavailable
Incident Report for Syncta
Resolved
Users can login to the application again. Technicians are working to investigate root cause to ensure this issue does not happen again. Please reach out to us if you have questions or concerns.
Posted Jan 29, 2018 - 14:28 PST
Investigating
Users are currently unable to login to the application. We apologize for the inconvenience. Technicians are working to restore functionality as soon as possible.
Posted Jan 29, 2018 - 14:26 PST