Partial Outage
Incident Report for Syncta
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 15:34 PST
Monitoring
Testing went well and today our team ran a script that changed the tests back to the appropriate status after the issue that moved them to submitted status on Thursday February 24th.

Now that the change is complete, please review your tests in different statuses to make sure they look correct.

Any test that was not already in submitted status at 6pm PST Wednesday was moved back to the status it was at then. This means that if a test was changed to a different status (such as pending review) it may now be back in the status it was at previously (such as scheduled or pending test). Another example is you may notice that some tests you approved from the pending review page will now be back in pending review and need to be approved again.

It is important to have someone check all the tests they updated between Wednesday at 6pm PST and this morning when we completed the change to make sure they are in the correct status.

If a second test was created while waiting for us to fix this, you will now have duplicate tests for an assembly. You can delete one of those at this point and you can continue using the other one.

Thank you for your patience and understanding as we worked to correct this issue over the past few days. We will be performing a full investigation into what happened and implement the necessary steps to ensure that this issue does not occur again in the future.
Posted Mar 01, 2022 - 11:40 PST
Update
Today our team continued testing the script that will change tests back to their appropriate statuses after the issue that occurred on Thursday, February 24th.

We found some changes that needed to be made during our testing this weekend, so we are performing a final round of testing this evening before we deploy the update in the morning. We are doing everything we can to ensure that this solution has been thoroughly verified before running it on all the affected tests.

We will be sending out a notice to everyone when this is complete so you can check your data. As a reminder, any new tests entered into Syncta after 6:00 p.m. PST on Wednesday, February 23rd are not affected by this issue.

Thank you again for your patience and understanding as we work to resolve this issue.
Posted Feb 28, 2022 - 16:26 PST
Update
Today our team continued to work on changing the tests back to their appropriate statuses after the issue that occurred on Thursday, February 24th.

We are currently testing a script that will make the necessary changes to these test statuses. Testing is going well so far, but we are going to continue to test this script through this weekend to ensure that the solution has been thoroughly verified before running it on all the affected tests.

If testing goes well this weekend, we are targeting to have this update implemented on Monday morning. We will be sending a notice out to everyone when this is complete so you can check your data.

After the change is implemented, we encourage you to review your tests in different statuses to make sure they look correct.
Any test that was not already in a submitted status at 6:00 p.m. PST Wednesday will be moved back to the status it was in then. This means that if a test was changed to a different status (such as to pending review) yesterday or today, it will be changed back to the status it was in previously (such as scheduled or pending test). You may notice that some of the tests you approved from the Pending Review page will also be back in the pending review status, so you will need approve them again.

It is important that you have someone check all the tests that were updated between Wednesday at 6:00 p.m. PST and Monday morning to ensure that they are in the correct status.

If you created a second test while you were waiting for us to fix this, you will have duplicate tests for an assembly. As of Monday morning, you can delete one of those tests, and then continue using the other one as usual.

Again, we are deeply sorry for the inconvenience and frustration this has caused you and your team but want you to know that we are working hard to correct the data as quickly and accurately as possible.

We will update you as soon as the tests have been corrected on Monday.
Posted Feb 25, 2022 - 18:23 PST
Identified
Today we identified an issue that caused tests in many different statuses (pending, scheduled, pending retest, retest hold, pending review, pending submission, etc.) to automatically change to a submitted status, even though they were not actually submitted or completed.

This means that you are unable to edit those existing tests, since they are locked when in a submitted status. This issue only affects tests that were entered before this morning, so you can continue to enter new tests in Syncta as usual.

So far, we have restored all of the scheduled tests back to the scheduled status, but there are many tests that were previously in other statuses that still need to be corrected.

Our developers are working to restore these tests to their previous statuses as quickly as possible but fixing all of them could potentially take a few days to complete. If you cannot wait for us to fix these existing tests, you can manually re-enter test information and proceed as normal.

We understand the impact that this issue has had on your business and are deeply sorry for the inconvenience and frustration it is causing you and your team. We will continue to provide you with updates as tests are corrected.

We want to reassure you that any new tests entered after this morning are not affected by this issue, and that resolving this is our top priority.
Posted Feb 24, 2022 - 17:19 PST
Update
We are continuing to investigate this issue.
Posted Feb 24, 2022 - 08:23 PST
Investigating
Users are currently unable to access Test data from Syncta Dashboard. Customer's are also reporting tests missing from pending tests as well. We are actively investigating this issue and working to restore service as soon as possible. We are very sorry for the inconvenience and will keep you posted on progress. Thanks for your patience and understanding.
Posted Feb 24, 2022 - 06:41 PST
This incident affected: Main application.