Forms taking longer than normal to update
Incident Report for Syncta
Resolved
Developers have identified and resolved the issue.
Posted Apr 19, 2021 - 13:23 PDT
Investigating
Currently forms are taking longer than normal to update in Syncta. The development team is working to resolve this issue with top priority. We apologize for the inconvenience. We will update you when it has been resolved. Thank you.
Posted Apr 19, 2021 - 12:15 PDT
This incident affected: Main application.